logotip

Библиотека WordPress — Во время загрузки произошла ошибка?


error[1]Приветствую! Есть вещи которые не столь страшные, но в тоже время могут выбить нас из колеи комфорта. Сегодня у меня техническая статья, связанная с блогом на вордпресс. Долгое время у меня был реальный глюк с библиотекой файлов, и при попытки опубликовать очередную статью на блоге с картинкой, приходилось делать лишние телодвижения, которые со временем всё больше напрягали.

В общем библиотека, не подгружала напрямую изображения и выдавала ошибку  — Во время загрузки произошла ошибка. Пожалуйста, повторите попытку позже. Возможно многие сталкиваются с подобной проблемой, когда Библиотека WordPress висит на белом фоне, картинки добавляются на сервер, но в самой библиотеки не хотят отображаться…

Как отображается ошибка с библиотекой WordPress?

  1. Белый фон в библиотеки файлов
  2. При загрузке изображения выдается ошибка — Во время загрузки произошла ошибка. Пожалуйста, повторите попытку позже.
  3. При этом само изображение появляется в библиотеке, на сервере. Но в библиотеки при добавлении из статьи, мы его не видим, и приходится копировать url картинки, чтобы вставить в статью
  4. В админке присутствует пустая белая строка, сразу под главной навигационной панелью.
  5. При установке дефолтного (стандартного) шаблона, проблема может решиться (но не факт!)
  6. Возможна проблема с одобрением комментариев, словно комментарии не добавляются, но на самом деле они уже на сайте… (как будто проблема с ajax или query)

Видео ошибки и решение проблемы (посмотрите до конца, у видео 2 части):

Что нужно чтобы решить проблему с библиотекой файлов, чтобы не возникало проблем с загрузкой изображений?

  • Вспомнить какой файл в движке или в шаблоне вы редактировали последний раз, и проверить кодировку (должна стоять UTF-8 без BOT)
  • Для смены кодировки необходим редактор notepad++ (найти можно в гугле, в видео показан сайт…)
  • Возможно проблема кроется в плагинах, которые пробуем отключать поочередно (но все же, мало вероятно в них)

reshenie-voprosy[1]

И вроде всё это ерунда с одной стороны… Ну зайди лишний раз в библиотеку, скопируй ссылку на изображение, а потов воткни фото в статью, подгрузив урл картинки. Но эти лишние движения со временем так надоедают, что не хочется порой писать даже статью на блог. И вот сегодня было решено от этого глюка избавиться во чтобы то не стало. Тем более в интернете на эту тему реально тишина… Все либо ставят ворпресс с нуля, переустанавливая, либо как то случайно натыкаются, проблему решают, но однажды она может возникнуть вновь, а решения не известно.

В общем, во многом, методом тыка добрался я до этой проблемы. И не знаю на 100% такая ли ситуация у вас, но у моя причина была именно в неправильной кодировке файлов шаблона и ещё одного файла движка вордпресс, в который однажды залез внести небольшие настройки открыв его через обычный виндовский блокнот… и в шаблонах также раз покапался. И всё! Непонятно почему, но как то незаметно для человеческого глаза, возникла эта тупая проблема.

А оказалось — что, старый добрый блокнот от виндовс, нужно выкинуть раз и навсегда, и ни в коем случае не редактировать файлы на сервере, через блокнот.

Кто бы мог подумать, но я по-чесноку, не знал, о том, что есть 2 вида кодировки файлов — UTF-8 и UTF-8 (Без BOM) . И все файлы, особенно на движке вордпресс, желательно содержать именно во второй кодировке.

Если сильно не вдаваться в литературу, то суть в том, что  когда файл сохранен в стандартной UTF-8 кодировке, у него в самом начале присутствует информация в 3 байта

А если немного углубиться, то когда была разработана ещё  кодировка UTF 16 (до UTF 8) , то её разработчики внедрили в неё такую штуку, чтобы была возможность записи символов как прямой, так и в обратной последовательности (нашел инфу на одном умном сайте…). И для того, чтобы программы могли понять в какой последовательности производить чтение символов в кодировке утф 16, была придумана специальная сигнатура под названием BOM (Byte Order Mark), которая и добавляла три дополнительных байта в самом начале документа.

А в кодировке UTF 8, сигнатуры BOM предусмотрено не было, и некоторым программам это мешало читать кодировку Юникод. И выбирая кодировку без BOM, может избавить как от отображения кракозябр (которые кстати могут возникнуть и при смене других кодировок. Сервер работает в одной, а файл даем в другой. В результате чего и получаем каракули на экране…), так и от различных глюков, таких как появился с библиотекой файлов у меня, на движке wordpress.

Просто некоторые программы в Windows не умеют сохранять текст в кодировке в UTF 8 без BOM. Как пример — блокнот. Открывая через блокнот файлы на нашем сервере, и сохраняя их, блокнот сохраняет документ в UTF 8 и добавляет в его начало три дополнительных байта. Вроде мелочь, но как долго она напрягала меня.

Кстати! Если обратите внимание — то под каждой кодировкой, UTF 8 и UTF 8 без BOM — файл будет иметь разный размер.

Тут уже не сложно догадаться от чего возникает проблема с библиотекой файлов и выдается ошибка  — Во время загрузки произошла ошибка. Пожалуйста, повторите попытку позже.
Иногда, мы можем покапаться в файлах движка, или в файлах шаблона. А многие могут заметить, как проблема с библиотекой файлов решается, когда ставится дефолтный шаблон wordpress (это просто знак свыше — значит какой то файл шаблона сохранен не в той кодировке. Просто окрываем каждый файл через notepad++ и пробиваем кодировку на нужную. В данном случае делаем всем файлам кодировку UTF 8 без BOM)

Не пугайтесь, что придется менять кучу файлов. По всей видимости проблема кроется в одном, двух файлах…. в который вы не так давно внесли изменения. Может форму подписки добавляли, может ещё что корректировали. Туда, сюда… сохранили пошли к следующему файлу, затем отвлеклись, телек посмотрели — проблема сразу не показалась Вам. Но всё же проблема возникла. А через день, или идем на блог, чтобы написать статейку, и Опа… а картинки не хотят грузиться через библиотеку. Вот и пойми сразу, что к чему. Толи плагин сбой дал, а может что-нибудь на стороне сервера.

И в общем при попытки решить проблему, уходит не мало времени. А добавлять статью можно, и картинки подгружать… Но ко всему прочему, добавляется лишнее движение, которое нам просто не нужно.

Кстати! Не факт, что у вас тоже проблемы с кодировкой… Но судя по всем найденным вопросам в сети, у большинству бы помогла именно эта статья. А так и встречал тех, кто решил проблему с помощью:

Полной переустановкой движка wordpress

Поочередным отключением установленным плагинам (присматриваются особенно к кешируемым плагинам)

…так что же ещё встречал? Мм…ммм…

В общем, кто что не советовал многим, говорили и проблемы со стороны хостинга могут быть… и проблемы в каком-нибудь плагине, не известно каком. В общем ребята разбирайтесь сами, всем говорили. Так и я раз в месяц смотрел быстрое решение этой проблемы, и не находил…

И так месяца три жил с этой бедой. Пока не сел однажды, не выделил пару часиков, чтобы самостоятельно вникнуть в суть этой ошибки на wordpress.

В общем, сильно не грузите меня если это вам не поможет. Потому как 100% должно помочь именно это (смена кодировки файлов)! В любом случае пишите в комментариях, чем смог помочь помог. Если вам не помогло, то думаю найдутся желающие развить эту тему до полного решения возможной проблемы.

А у меня пожалуй всё!

Пишите обязательно — помогло или нет:

Автор публикации

не в сети 12 минут

Денис Повага

Нужна помощь? Пишите ниже или в одноклассниках: ok.ru/denis.povaga

Комментарии: 2061Публикации: 533Регистрация: 12-03-2013

Набор текста на дому

Вы тоже можете стать редактором блога и зарабатывать не выходя из дома. Присоединяйтесь к сообществу 1000+ блогеров, чтобы приступить к делу...



Комментариев к статье: 32
  • в 13:53
    ссылка

    Помогло следующее:
    При возникновении проблем с загрузкой изображений в библиотеку – добавить строку define(‘CONCATENATE_SCRIPTS’, false ); в wp-config.php перед require_once(ABSPATH . ‘wp-settings.php’);

    Ответить
  • в 10:20
    ссылка

    Огромное спасибо! Долго искал решение этой проблемы и нашел ответ только у вас)

    Ответить
  • в 20:08
    ссылка

    Да, проблема решена, НО:
    Боже, чувак, ну что у тебя с аудиодорожкой ролика? Делаешь вроде все правильно, но слушать невозможно. По сто раз одно и то же. Ты б готовил видео — записал примерно речь на бумажке, а потом по ней примерно прочитал. Лучше будет и приятнее смотреть/слушать! Удачи тебе

    Ответить
  • в 14:53
    ссылка

    автор, ууф у меня типичная ситуация!только не знаю как редактировать , скопировала текущий код в нотепад перевела его в UTF-8 (Без BOM) а дальше?? помогите пожалуйста( уже вторую неделю сижу с этой косячной библиотекой. задолбалась (

    Ответить
    • в 16:02
      ссылка

      перевели в UTF-8 (Без BOM), а дальше пересохраняете его на своем сервере. Или удалили старый, который в простой UTF-8 кодировке, и уже исправленный залили. Только предварительно копию не забывайте делать. мало ли чего… По всей видимости какой то один файл или несколько находятся в не той кодировки. я помню, месяца 3 сидел с этой проблемой, тоже руки не доходили разбираться. Вроде мелочь, а не приятная ))

      Если возникнут затруднения, пишите. Постараюсь помочь!

      Ответить
  • в 16:53
    ссылка

    Здравствуйте! Ничего из предложенного не помогает. В чем может быть еще причина? Может вордпресс глючит?

    Ответить
    • в 20:42
      ссылка

      Проблема явно в файлах или в шаблоне. Если после обновления движка вордпресс проблема не решилась, то скорее всего в шаблоне. Попробуйте поменять на стандартный. Решится ли проблема?

      Ответить
      • в 17:51
        ссылка

        Я поменял на стандартные и все картинки сразу появились. Но при проверке фалов моего шаблона на BOM проблем нет. Все фалы сохранены правильно. что делать?

        Ответить
  • в 22:47
    ссылка

    У меня было так. Для удобства использовал в названиях русские слова. С такими изображениями вышеописанная проблема. При замене названия на латиницу все ОК. Может кому-то поможет. Да еще у меня установлен плагин RusToLat

    Ответить
  • в 01:31
    ссылка

    Спасибо за заметку! Хотя лично у меня проблема оказалась в другом (я еще начинаю разбираться с WP).

    Дело было так:
    1. создал свою под-тему (на основе стандартной) + добавил свой файл functions.php

    2. добавил туда код для отображения моих Кастомных Типов Записей в разделах стандартных Категорий и Архивов:
    function query_post_type($query){
    $query->set(‘post_type’,array(‘project’, ‘expert’));
    }
    add_filter(‘pre_get_posts’,’query_post_type’);

    3. и вот 🙁 Теперь не отображаются картинки в Медиафайлах и подгрузка новых картинок точно такие же проблемы выдает (как при сохранении с BOM)!

    ———————

    4. Решение — добавить проверку чтобы функция выполнялась только в разделах Категории и Архивов:
    function query_post_type($query){
    if (is_category() || is_archive()) {
    $query->set(‘post_type’,array(‘project’, ‘expert’));
    }
    }
    add_filter(‘pre_get_posts’,’query_post_type’);

    ——————-
    Возможно, для опытного профессионала будет странным смешным мой случай, но может кому-то будет полезно знать про возможный вариант развития событий! 🙂

    Ответить
  • в 11:26
    ссылка

    Спасибо огромное! Аналогичная проблема с медиагалереей WordPress была с одной из коммерческих тем от mythemeshop. Долго отлаживал код шаблона, но проблему решила смены кодировки у отредактированных php файлов на UTF 8 без BOM

    Ответить
  • в 01:26
    ссылка

    Не могу все равно решить эту проблему((( менял кодировки и в теме шаблона и на самом движке, помогите кто может уже 2 недели страдаю.

    Ответить
  • в 11:20
    ссылка

    Проблема была с кодировкой некоторых файлов, я их кодировал в utf-8 обычный, хотя при кодировании в utf-8(без BOM) изображения успешно стали появляться. Спасибо за статью, очень помогла, еще одна ценная и полезная информация в мою копилку веб мастера.

    Ответить
  • в 22:39
    ссылка

    Благодарю за инструкцию, уже думал тему выбрасывать. Почитав ваши наставления, вспомнил, что один файл как раз сохранил UTF-8, пересохранил в UTF-8 без BOT и о чудо, все заработало. Спасибо еще раз )

    Ответить
  • в 16:28
    ссылка

    Дружище, спасибо. Я и в самом деле копировал файл с ФТП, кое-что изменил и сохранил стандартно через блокнот. Твой способ работает. Респект в общем тебе )))

    Ответить
    • в 12:43
      ссылка

      Спасибо, ОП, нашел косячный файл, избавился от проблемы! От души!

      Ответить
  • в 15:54
    ссылка

    Помогло! Поменял кодировку без BOT в файле wp-config. Спасибо!

    Ответить
  • в 22:46
    ссылка

    Спасибо , статья помогла. Я делал так: залил исходные файлы темы, все заработало, а потом добавил файлы в которых делал изменения. Все заработало!

    Ответить
  • в 22:34
    ссылка

    Ну просто супер!
    У меня оказывается в function.php
    нужно было кодировку сменить…
    Я уже весь инет облазил, а правильное решение только здесь и нашел 🙂

    Ответить
  • в 16:12
    ссылка

    Спасибо большое! И у меня так же в файле function.php кодировка стояла с бом, поменял на utf-8 без бом и все заработало.

    Ответить
  • в 01:19
    ссылка

    Здравствуйте! Вот и у меня такая же проблема. делаю все по инструкцию, но появляется другая проблема, при загруски на сервер выдает критическое ошиб в красном цвете, т е не загружается. некоторые php файлы были обычные, я их поменял на (без БОТ) . тему поменял на другие, все равно проблема не решается. не знаю что делать. Помогите пожалуйста!

    Ответить
  • в 08:34
    ссылка

    Привет!
    Большое спасибо! Помогло!
    Я уже когда-то сталкивался с данной проблемой, и вопрос решился сам (скопировал сохраненный файл и все)
    Но на этот раз проблема была глобальной… Я много правил, проверял. И вроде все настроил, работает — и вдруг не могу загрузить файл (не видит библиотеку)….

    Самое ценное:
    «А оказалось — что, старый добрый блокнот от виндовс, нужно выкинуть раз и навсегда, и ни в коем случае не редактировать файлы на сервере, через блокнот.

    Кто бы мог подумать, но я по-чесноку, не знал, о том, что есть 2 вида кодировки файлов — UTF-8 и UTF-8 (Без BOM) . И все файлы, особенно на движке вордпресс, желательно содержать именно во второй кодировке.

    Если сильно не вдаваться в литературу, то суть в том, что когда файл сохранен в стандартной UTF-8 кодировке, у него в самом начале присутствует информация в 3 байта»

    Спасибо!

    Ответить
    • в 11:02
      ссылка

      Да, всё верно. Помню как я сам долго искал эту проблему. Было даже время, когда не хотелось писать новую статью из-за этой ошибки. Ведь было неудобно вручную загружать изображения, минуя библиотеку. А после, когда всё же добрался до истины, — было приятно узнать этот нюанс. Причем тоже самое встречал и после, только не с библиотекой, а с базой данных. Ошибка может возникать и в те моменты, когда файл подключается к базе данных, и если файл будет в стандартной utf-8, это тоже может выдавать ошибку. Обычно в виде белой страницы!

      Ответить
  • в 20:26
    ссылка

    Мне помогло другое. Взял с какого-то форума:
    «Решений проблемы есть несколько. Судя по своему опыту Вам скорей всего подойдет такое решение:
    добавить в wp-config.php данный код (например после строки — /* Это всё, дальше не редактируем. Успехов! */) define(‘CONCATENATE_SCRIPTS’, false);

    Если не поможет — необходимо найти в файле functions.php(находится в папке wp-includes в каталоге вашего сайта) строку

    function wp_ext2type( $ext )

    и добавить в данную функцию строку

    ‘image’ => array( ‘jpg’, ‘jpeg’, ‘gif’, ‘tiff’, ‘png’),

    так чтобы функция стала выглядеть как

    function wp_ext2type( $ext ) {
    $ext2type = apply_filters( ‘ext2type’, array(
    ‘image’ => array( ‘jpg’, ‘jpeg’, ‘gif’, ‘tiff’, ‘png’),
    ‘audio’ => array( ‘aac’, ‘ac3’, ‘aif’, ‘aiff’, ‘m3a’, ‘m4a’, ‘m4b’, ‘mka’, ‘mp1’, ‘mp2’, ‘mp3’, ‘ogg’, ‘oga’, ‘ram’, ‘wav’, ‘wma’ ),
    ‘video’ => array( ‘asf’, ‘avi’, ‘divx’, ‘dv’, ‘flv’, ‘m4v’, ‘mkv’, ‘mov’, ‘mp4’, ‘mpeg’, ‘mpg’, ‘mpv’, ‘ogm’, ‘ogv’, ‘qt’, ‘rm’, ‘vob’, ‘wmv’ ),
    ‘document’ => array( ‘doc’, ‘docx’, ‘docm’, ‘dotm’, ‘odt’, ‘pages’, ‘pdf’, ‘rtf’, ‘wp’, ‘wpd’ ),
    ‘spreadsheet’ => array( ‘numbers’, ‘ods’, ‘xls’, ‘xlsx’, ‘xlsm’, ‘xlsb’ ),
    ‘interactive’ => array( ‘swf’, ‘key’, ‘ppt’, ‘pptx’, ‘pptm’, ‘pps’, ‘ppsx’, ‘ppsm’, ‘sldx’, ‘sldm’, ‘odp’ ),
    ‘text’ => array( ‘asc’, ‘csv’, ‘tsv’, ‘txt’ ),
    ‘archive’ => array( ‘bz2’, ‘cab’, ‘dmg’, ‘gz’, ‘rar’, ‘sea’, ‘sit’, ‘sqx’, ‘tar’, ‘tgz’, ‘zip’, ‘7z’ ),
    ‘code’ => array( ‘css’, ‘htm’, ‘html’, ‘php’, ‘js’ ),
    ));
    foreach ( $ext2type as $type => $exts )
    if ( in_array( $ext, $exts ) )
    return $type;
    }

    После этого загрузка должна заработать корректно.

    Если и после этого не работает, проверьте права на папку «uploads» — должны быть 755 или 777.»

    Ответить

Добавить комментарий

Вход на сайт в 1 клик: 

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Авторизация
*
*
Вход на сайт в 1 клик: 
Регистрация
*
*
*
Вход на сайт в 1 клик: 
Генерация пароля